package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?:\/\/)?(www\.)?instagram.com\/p\/[a-zA-Z0-9]{4,20}\/?`)
var str = `https://www.instagram.com/p/CiqWEQMOVNo/
https://www.instagram.com/p/CiqWEQMOVNo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}