import re
regex = re.compile(r"^(https?:\/\/)?(www\.)?instagram.com\/p\/[a-zA-Z0-9]{4,20}\/?", flags=re.MULTILINE)
test_str = ("https://www.instagram.com/p/CiqWEQMOVNo/\n"
"https://www.instagram.com/p/CiqWEQMOVNo")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")