import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?:\\/\\/)?(www\\.)?instagram.com\\/p\\/[a-zA-Z0-9]{4,20}\\/?";
final String string = "https://www.instagram.com/p/CiqWEQMOVNo/\n"
+ "https://www.instagram.com/p/CiqWEQMOVNo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}