import Foundation
let pattern = #" +(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" disabled hide="a1, a2, a3" active"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)