using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\W?Y{2,4}\W?";
string input = @"
YYYY-MM-DD
D/MM/YY
M/D/YYYY
YYYY/MM/DD
YYYY.MM.DD
MM/DD/YYYY
DD-MM-YYYY
DD-MMM-YY
DD/MMM/YYYY
DD.MMM.YYYY
DD.MM.YYYY";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}