// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\W?Y{2,4}\W?").unwrap();
let string = "
YYYY-MM-DD
D/MM/YY
M/D/YYYY
YYYY/MM/DD
YYYY.MM.DD
MM/DD/YYYY
DD-MM-YYYY
DD-MMM-YY
DD/MMM/YYYY
DD.MMM.YYYY
DD.MM.YYYY";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}