$re = '/\W?Y{2,4}\W?/m';
$str = '
YYYY-MM-DD
D/MM/YY
M/D/YYYY
YYYY/MM/DD
YYYY.MM.DD
MM/DD/YYYY
DD-MM-YYYY
DD-MMM-YY
DD/MMM/YYYY
DD.MMM.YYYY
DD.MM.YYYY';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);