#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/(?!.*\.(?:php|jpg|html)$)[^\/]+$"
Local $sString = "www.mysite.com/page" & @CRLF & _
"www.mysite.com/page/" & @CRLF & _
"www.mysite.com/file.php" & @CRLF & _
"www.mysite.com/file.jpg" & @CRLF & _
"www.mysite.com/file.html" & @CRLF & _
"www.mysite.com/file.doc"
Local $sSubst = "$0\/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)