const regex = /\/(?!.*\.(?:php|jpg|html)$)[^\/]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(?!.*\\.(?:php|jpg|html)$)[^\\\/]+$', 'gm')
const str = `www.mysite.com/page
www.mysite.com/page/
www.mysite.com/file.php
www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc`;
const subst = `$0\/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);