use strict;
my $str = 'www.mysite.com/page
www.mysite.com/page/
www.mysite.com/file.php
www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc';
my $regex = qr/\/(?!.*\.(?:php|jpg|html)$)[^\/]+$/mp;
my $subst = '$0\\/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";