package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-zçÇğĞıİöÖşŞüÜ ]+) ([A-zçÇğĞıİöÖşŞüÜ ]+)$`)
var str = `FirstName LastName
FirstName MiddleName LastName
SingleName
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}