re = /^([A-zçÇğĞıİöÖşŞüÜ ]+) ([A-zçÇğĞıİöÖşŞüÜ ]+)$/m
str = 'FirstName LastName
FirstName MiddleName LastName
SingleName
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end