$re = '/^([A-zçÇğĞıİöÖşŞüÜ ]+) ([A-zçÇğĞıİöÖşŞüÜ ]+)$/m';
$str = 'FirstName LastName
FirstName MiddleName LastName
SingleName
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);