import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z0-9\\.-_]+@[\\w\\d]+\\.\\w+";
final String string = "ivan@example.com\n"
+ "i.v.a.n.@example.com\n"
+ "_i_v_a_n_@example.com\n"
+ "ivan@perro.gato\n"
+ "ivan@perro.gato.com\n"
+ "ivan+@example.com\n"
+ "email@domain.com\n"
+ "firstname.lastname@domain.com\n"
+ "email@subdomain.domain.com\n"
+ "firstname+lastname@domain.com\n"
+ "email@123.123.123.123\n"
+ "email@[123.123.123.123]\n"
+ "\"email\"@domain.com\n"
+ "1234567890@domain.com\n"
+ "email@domain-one.com\n"
+ "_______@domain.com\n"
+ "email@domain.name\n"
+ "email@domain.co.jp\n"
+ "firstname-lastname@domain.com\n"
+ "plainaddress\n"
+ "#@%^%#$@#$@#.com\n"
+ "@domain.com\n"
+ "Joe Smith <email@domain.com>\n"
+ "email.domain.com\n"
+ "email@domain@domain.com\n"
+ ".email@domain.com\n"
+ "email.@domain.com\n"
+ "email..email@domain.com\n"
+ "あいうえお@domain.com\n"
+ "email@domain.com (Joe Smith)\n"
+ "email@domain\n"
+ "email@-domain.com\n"
+ "email@domain.web\n"
+ "email@111.222.333.44444\n"
+ "email@domain..com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}