const regex = /(?:\w{2,}\.[^\S\n]+)+|[^\w\s]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\w{2,}\\.[^\\S\\n]+)+|[^\\w\\s]+', 'gm')
const str = `DR. Tida.
prof. Sina.
DR. prof. Tida.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);