re = /(?:\w{2,}\.[^\S\n]+)+|[^\w\s]+/m
str = 'DR. Tida.
prof. Sina.
DR. prof. Tida.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result