#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\d{1,3}(?!\d)(?:\h*[a-zA-Z]\b)?)[^|\n]*\h*(?:$|[|(])$"
Local $sString = "Lilienstr. 12a" & @CRLF & _
"Hagentorwall 3 " & @CRLF & _
"Seilerstr. 14 (Eingang Birkenstr.)" & @CRLF & _
"Guentherstr. 43 B" & @CRLF & _
"" & @CRLF & _
"Eberhard-Leibnitz Str. 1 WH 5B 241" & @CRLF & _
"1019-1781 Borderlinx C/O SEKO Logistics" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")