$re = '/\b(\d{1,3}(?!\d)(?:\h*[a-zA-Z]\b)?)[^|\n]*\h*(?:$|[|(])$/m';
$str = 'Lilienstr. 12a
Hagentorwall 3
Seilerstr. 14 (Eingang Birkenstr.)
Guentherstr. 43 B
Eberhard-Leibnitz Str. 1 WH 5B 241
1019-1781 Borderlinx C/O SEKO Logistics
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);