import re
regex = re.compile(r"\b(\d{1,3}(?!\d)(?:\h*[a-zA-Z]\b)?)[^|\n]*\h*(?:$|[|(])$", flags=re.MULTILINE)
test_str = ("Lilienstr. 12a\n"
"Hagentorwall 3 \n"
"Seilerstr. 14 (Eingang Birkenstr.)\n"
"Guentherstr. 43 B\n\n"
"Eberhard-Leibnitz Str. 1 WH 5B 241\n"
"1019-1781 Borderlinx C/O SEKO Logistics\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")