$re = '/^https?:\/\//m';
$str = 'http://www.example.com
https://www.example.com
Http://www.example.com
HTTp://www.example.com
hTTpS://www.example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);