// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?:\/\/").unwrap();
let string = "http://www.example.com
https://www.example.com
Http://www.example.com
HTTp://www.example.com
hTTpS://www.example.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}