re = /^https?:\/\//m
str = 'http://www.example.com
https://www.example.com
Http://www.example.com
HTTp://www.example.com
hTTpS://www.example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end