// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)assignments$").unwrap();
let string = "1.) https://beta-qa.pearson.com/iie-api/courses/5daa3022e4b0ef7dce37acec/assignments
2.) https://beta-qa.pearson.com/iie-api/courses/5daa3022e4b0ef7dce37acec/assignments/984fa00d-d002-4826-80f4-76d1267e3aaa
3.) https://beta-qa.pearson.com/iie-api/courses/5daa3022e4b0ef7dce37acec/assignments/984fa00d-d002-4826-80f4-76d1267e3aaa/assignments";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}