import Foundation
let pattern = #"assignments$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.) https://beta-qa.pearson.com/iie-api/courses/5daa3022e4b0ef7dce37acec/assignments
2.) https://beta-qa.pearson.com/iie-api/courses/5daa3022e4b0ef7dce37acec/assignments/984fa00d-d002-4826-80f4-76d1267e3aaa
3.) https://beta-qa.pearson.com/iie-api/courses/5daa3022e4b0ef7dce37acec/assignments/984fa00d-d002-4826-80f4-76d1267e3aaa/assignments
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)