const regex = /^\d+(\.?\d+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(\\.?\\d+)*$', 'gm')
const str = `111111111d
(Try adding 1 before the d; every digit will double the execution time - exponential growth. This is BAD!)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}