$re = '/^\d+(\.?\d+)*$/m';
$str = '111111111d
(Try adding 1 before the d; every digit will double the execution time - exponential growth. This is BAD!)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);