// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(\.?\d+)*$").unwrap();
let string = "111111111d
(Try adding 1 before the d; every digit will double the execution time - exponential growth. This is BAD!)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}