#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{1,100}$)[a-zA-Z0-9]+(?:[-.][a-zA-Z0-9]+)*$"
Local $sString = "GOOD:" & @CRLF & _
"" & @CRLF & _
"asd.asd.asd.asd.asd.aadas.asdasdasd" & @CRLF & _
"" & @CRLF & _
"as-d.asd.a-sd" & @CRLF & _
"" & @CRLF & _
"BAD:" & @CRLF & _
"" & @CRLF & _
".asd.asd" & @CRLF & _
"" & @CRLF & _
"-asd.-asd" & @CRLF & _
"" & @CRLF & _
".-asd.asd" & @CRLF & _
"" & @CRLF & _
"asd.asd." & @CRLF & _
"" & @CRLF & _
"asd.asd-" & @CRLF & _
"" & @CRLF & _
"asd.asd.-" & @CRLF & _
"" & @CRLF & _
"asd.asd-." & @CRLF & _
"" & @CRLF & _
"asd.asd--" & @CRLF & _
"" & @CRLF & _
"asd.." & @CRLF & _
"" & @CRLF & _
"asd.asd-.asd" & @CRLF & _
"" & @CRLF & _
".-" & @CRLF & _
"" & @CRLF & _
"asd--asd..asd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")