$re = '/^(?=.{1,100}$)[a-zA-Z0-9]+(?:[-.][a-zA-Z0-9]+)*$/m';
$str = 'GOOD:
asd.asd.asd.asd.asd.aadas.asdasdasd
as-d.asd.a-sd
BAD:
.asd.asd
-asd.-asd
.-asd.asd
asd.asd.
asd.asd-
asd.asd.-
asd.asd-.
asd.asd--
asd..
asd.asd-.asd
.-
asd--asd..asd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);