import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{1,100}$)[a-zA-Z0-9]+(?:[-.][a-zA-Z0-9]+)*$";
final String string = "GOOD:\n\n"
+ "asd.asd.asd.asd.asd.aadas.asdasdasd\n\n"
+ "as-d.asd.a-sd\n\n"
+ "BAD:\n\n"
+ ".asd.asd\n\n"
+ "-asd.-asd\n\n"
+ ".-asd.asd\n\n"
+ "asd.asd.\n\n"
+ "asd.asd-\n\n"
+ "asd.asd.-\n\n"
+ "asd.asd-.\n\n"
+ "asd.asd--\n\n"
+ "asd..\n\n"
+ "asd.asd-.asd\n\n"
+ ".-\n\n"
+ "asd--asd..asd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}