package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+(?:-\d+)?\+?)\s*(years?)`)
var str = `10+ years
10 years
1 year
10-15 years`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}