$re = '/(\d+(?:-\d+)?\+?)\s*(years?)/m';
$str = '10+ years
10 years
1 year
10-15 years';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);