re = /(\d+(?:-\d+)?\+?)\s*(years?)/m
str = '10+ years
10 years
1 year
10-15 years'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end