#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Item.+"
Local $sString = "Parker Tech" & @CRLF & _
"74 Lincoln Green Lane" & @CRLF & _
"Church Stoke, PA 19402" & @CRLF & _
"(123) 456-7890" & @CRLF & _
"Invoice" & @CRLF & _
"Submitted on 9/9/2016" & @CRLF & _
"Invoice for" & @CRLF & _
"Name" & @CRLF & _
"Company name" & @CRLF & _
"Email" & @CRLF & _
"Street address" & @CRLF & _
"City, State, Zip" & @CRLF & _
"Payable to" & @CRLF & _
"Bobby John" & @CRLF & _
"Bobby Co." & @CRLF & _
"bobby@john.com" & @CRLF & _
"Project" & @CRLF & _
"Project name" & @CRLF & _
"Invoice #" & @CRLF & _
"12345" & @CRLF & _
"Due date" & @CRLF & _
"9/16/2016" & @CRLF & _
"Description Qty Unit price Total price" & @CRLF & _
"Item #1 1 $200.00 $200.00" & @CRLF & _
"Item #2 2 $200.00 $400.00" & @CRLF & _
"$0.00" & @CRLF & _
"$0.00" & @CRLF & _
"Notes: Subtotal $600.00" & @CRLF & _
"Adjustments -$100.00" & @CRLF & _
"$500.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")