import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Item.+";
final String string = "Parker Tech\n"
+ "74 Lincoln Green Lane\n"
+ "Church Stoke, PA 19402\n"
+ "(123) 456-7890\n"
+ "Invoice\n"
+ "Submitted on 9/9/2016\n"
+ "Invoice for\n"
+ "Name\n"
+ "Company name\n"
+ "Email\n"
+ "Street address\n"
+ "City, State, Zip\n"
+ "Payable to\n"
+ "Bobby John\n"
+ "Bobby Co.\n"
+ "bobby@john.com\n"
+ "Project\n"
+ "Project name\n"
+ "Invoice #\n"
+ "12345\n"
+ "Due date\n"
+ "9/16/2016\n"
+ "Description Qty Unit price Total price\n"
+ "Item #1 1 $200.00 $200.00\n"
+ "Item #2 2 $200.00 $400.00\n"
+ "$0.00\n"
+ "$0.00\n"
+ "Notes: Subtotal $600.00\n"
+ "Adjustments -$100.00\n"
+ "$500.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}