# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Item.+"
test_str = ("Parker Tech\n"
"74 Lincoln Green Lane\n"
"Church Stoke, PA 19402\n"
"(123) 456-7890\n"
"Invoice\n"
"Submitted on 9/9/2016\n"
"Invoice for\n"
"Name\n"
"Company name\n"
"Email\n"
"Street address\n"
"City, State, Zip\n"
"Payable to\n"
"Bobby John\n"
"Bobby Co.\n"
"bobby@john.com\n"
"Project\n"
"Project name\n"
"Invoice #\n"
"12345\n"
"Due date\n"
"9/16/2016\n"
"Description Qty Unit price Total price\n"
"Item #1 1 $200.00 $200.00\n"
"Item #2 2 $200.00 $400.00\n"
"$0.00\n"
"$0.00\n"
"Notes: Subtotal $600.00\n"
"Adjustments -$100.00\n"
"$500.00")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.