package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\+7|8)((\-|\ |\(|\))*\d){10}$`)
var str = `+7 (916) 123-33 44`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}