const regex = /^(\+7|8)((\-|\ |\(|\))*\d){10}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+7|8)((\\-|\\ |\\(|\\))*\\d){10}$', 'g')
const str = `+7 (916) 123-33 44`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}