$re = '/^(\+7|8)((\-|\ |\(|\))*\d){10}$/';
$str = '+7 (916) 123-33 44';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);