using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?:\([^()]*) # Match '( ....'
(?:\d+,\ ){2,} # Our regex in '( ..... )'
(?:[^()]*\)) # Match '..... )'
(*SKIP)(*FAIL) # Fail the first alternative
| # Second alternative
(?:\d+,\ ){2,} # Our regex not enclosed in '( ... )'
";
string input = @"Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362 (Booboo)
Albemarle Paper Co. v Moody (1975) 422 US 405, 95 S Ct 2362
Aerotek, Inc. v Johnson Group Staffing Co. (July 30, 2013, C067652) 2013 Cal Unpub Lexis 5424";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}