use strict;
my $str = 'Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362 (Booboo)
Albemarle Paper Co. v Moody (1975) 422 US 405, 95 S Ct 2362
Aerotek, Inc. v Johnson Group Staffing Co. (July 30, 2013, C067652) 2013 Cal Unpub Lexis 5424';
my $regex = qr~ (?:\([^()]*) # Match '( ....'
(?:\d+,\ ){2,} # Our regex in '( ..... )'
(?:[^()]*\)) # Match '..... )'
(*SKIP)(*FAIL) # Fail the first alternative
| # Second alternative
(?:\d+,\ ){2,} # Our regex not enclosed in '( ... )'
~xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}