$re = '~ (?:\([^()]*) # Match \'( ....\'
(?:\d+,\ ){2,} # Our regex in \'( ..... )\'
(?:[^()]*\)) # Match \'..... )\'
(*SKIP)(*FAIL) # Fail the first alternative
| # Second alternative
(?:\d+,\ ){2,} # Our regex not enclosed in \'( ... )\'
~x';
$str = 'Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362 (Booboo)
Albemarle Paper Co. v Moody (1975) 422 US 405, 95 S Ct 2362
Aerotek, Inc. v Johnson Group Staffing Co. (July 30, 2013, C067652) 2013 Cal Unpub Lexis 5424';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);