re = /^\[(error|warn)\]\s+(.+?):(\d+):(?:(\d+):)?\s+(.+)$/m
str = '[error] C:\\Me\\MyPath\\myFile.scala:18:22: not found: value getaa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end