// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[(error|warn)\]\s+(.+?):(\d+):(?:(\d+):)?\s+(.+)$").unwrap();
let string = "[error] C:\\Me\\MyPath\\myFile.scala:18:22: not found: value getaa
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}