#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+\.(.+)\..+"
Local $sString = "www.table.google.com" & @CRLF & _
"www.table.google.com/test123" & @CRLF & _
"www.google.de" & @CRLF & _
"http://www.google.com" & @CRLF & _
"google.com" & @CRLF & _
"www.table.google.com/test123/www.google.de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")