$re = '/.+\.(.+)\..+/m';
$str = 'www.table.google.com
www.table.google.com/test123
www.google.de
http://www.google.com
google.com
www.table.google.com/test123/www.google.de';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);