import re
regex = re.compile(r".+\.(.+)\..+", flags=re.MULTILINE)
test_str = ("www.table.google.com\n"
"www.table.google.com/test123\n"
"www.google.de\n"
"http://www.google.com\n"
"google.com\n"
"www.table.google.com/test123/www.google.de")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")