package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-f0-9\\-]+)`)
var str = `d1a2227e-291f-4d82-8991-b9458b4ad0d3","fb48e632-3c85-483b-86b3-76f7a1c7eb25","93fa5301-29e2-4ef6-9353-686868686888`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}