import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-f0-9\\\\-]+)";
final String string = "d1a2227e-291f-4d82-8991-b9458b4ad0d3\",\"fb48e632-3c85-483b-86b3-76f7a1c7eb25\",\"93fa5301-29e2-4ef6-9353-686868686888";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}