// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-f0-9\\-]+)").unwrap();
let string = "d1a2227e-291f-4d82-8991-b9458b4ad0d3\",\"fb48e632-3c85-483b-86b3-76f7a1c7eb25\",\"93fa5301-29e2-4ef6-9353-686868686888";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}